Множественные уязвимости в Atlassian Confluence

Дата публикации:
21.04.2011
Всего просмотров:
862
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
6
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:L/Au:S/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:5.5/Temporal:4.1
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Atlassian Confluence 3.x
Уязвимые версии: Atlassian Confluence версии до 3.5.3

Описание:
Уязвимость позволяет удаленному пользователю обойти некоторые ограничения безопасности.

1. Уязвимость существует из-за недостаточной обработки входных данных в макросе "{doc}". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в макросе "{toc}". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за недостаточной обработки входных данных в дополнениях Space Names, Office Connector и Tasklist Macro. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

4. Уязвимость существует из-за ошибки в функционале Remote API. Авторизованный пользователь может выполнять некоторые действия с повышенными привилегиями.

5. Уязвимость существует из-за недостаточной обработки входных данных в дополнениях Login и User Preferences при редактировании настроек. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

6. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий. Удаленный пользователь может произвести CSRF нападение и добавить закладки.

URL производителя: http://www.atlassian.com/software/confluence/overview

Решение: Установите последнюю версию 3.5.3 с сайта производителя.

Ссылки: http://confluence.atlassian.com/x/HgdrDQ
http://confluence.atlassian.com/x/MgCzDQ
http://confluence.atlassian.com/x/mgtgDQ
http://confluence.atlassian.com/x/FAZ7DQ
http://jira.atlassian.com/browse/CONF-21508
http://jira.atlassian.com/browse/CONF-21819
http://jira.atlassian.com/browse/CONF-21740
http://jira.atlassian.com/browse/CONF-21963
http://jira.atlassian.com/browse/CONF-21964
http://jira.atlassian.com/browse/CONF-21162
http://jira.atlassian.com/browse/CONF-21479
http://jira.atlassian.com/browse/CONF-21402
http://jira.atlassian.com/browse/CONF-21565

или введите имя

CAPTCHA