Межсайтовый скриптинг в WordPress Daily Maui Photo Widget

Дата публикации:
08.04.2011
Всего просмотров:
560
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Daily Maui Photo Widget Plugin 0.x
Уязвимые версии: Daily Maui Photo Widget дополнение для WordPress 0.2, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "title" в сценарии wp-content/plugins/daily-maui-photo-widget/wp-dailymaui-widget-control.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "selected_small", "selected_medium", "selected_thumb", "selected_date" и "selected_full" в сценарии wp-content/plugins/daily-maui-photo-widget/wp-dailymaui-widget-control.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Примечание: Для успешной эксплуатации уязвимости параметр "register_globals" должен быть включен.

URL производителя: http://wordpress.org/extend/plugins/daily-maui-photo-widget/

Решение: Установите последнюю версию 0.3 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/daily-maui-photo-widget/changelog/
http://www.htbridge.ch/advisory/xss_in_daily_maui_photo_widget_wordpress_plugin.html

или введите имя

CAPTCHA