Межсайтовый скриптинг в Ruby on Rails

Дата публикации:
05.03.2012
Дата изменения:
05.03.2012
Всего просмотров:
701
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ruby on Rails 3.0.x
Ruby on Rails 3.1.x
Ruby on Rails 3.2.x
Уязвимые версии: Ruby on Rails 3.0.12
Ruby on Rails 3.1.4
Ruby on Rails 3.2.2

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в SafeBuffer. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных при выборе тегов. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://rubyonrails.org/

Решение: Установите последнюю версию с сайта производителя.



Ссылки: http://weblog.rubyonrails.org/2012/3/1/ann-rails-3-2-2-has-been-released
http://groups.google.com/group/rubyonrails-security/browse_thread/thread/edd28f1e3d04e913
http://groups.google.com/group/rubyonrails-security/browse_thread/thread/9da0c515a6c4664
или введите имя

CAPTCHA