Множественные уязвимости в Sysax Multi Server

Дата публикации:
29.02.2012
Дата изменения:
01.03.2012
Всего просмотров:
1059
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:C/I:C/A:C/E:F/RL:O/RC:C) = Base:10/Temporal:8.3
(AV:N/AC:L/Au:N/C:C/I:C/A:C/E:F/RL:O/RC:C) = Base:10/Temporal:8.3
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Sysax Multi Server 5.x
Уязвимые версии: Sysax Multi Server 5.53, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольный код на целевой системе.

. 1. Уязвимость существует из-за ошибки проверки границ данных при обработке запросов авторизации. Удаленный пользователь может с помощью специально сформированного авторизационного запроса вызвать переполнение буфера в стеке и выполнить произвольный код с привилегиями SYSTEM на целевой системе.

2. Уязвимость существует из-за ошибки в SSH компоненте при обработке запросов на получение данных. Удаленный пользователь может с помощью специально сформированного запроса на получение файлов вызвать переполнение буфера в стеке и выполнить произвольный код с привилегиями SYSTEM на целевой системе.

URL производителя: http://www.sysax.com/about.htm

Решение: Для устранения уязвимости установите версию 5.55 с сайта производителя.

Ссылки: http://www.exploit-db.com/exploits/18535/
http://www.pwnag3.com/2012/02/sysax-multi-server-ssh-username-exploit.html
http://www.pwnag3.com/2012/02/sysax-multi-server-553-sftp-exploit.html
http://www.exploit-db.com/exploits/18534/

или введите имя

CAPTCHA