SQL-инъекция в TestLink

Дата публикации:
24.02.2012
Дата изменения:
24.02.2012
Всего просмотров:
726
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
5
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:P/I:P/A:N/E:ND/RL:O/RC:C) = Base:5.8/Temporal:0
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:ND/RL:O/RC:C) = Base:6.4/Temporal:0
(AV:N/AC:M/Au:N/C:P/I:P/A:N/E:ND/RL:O/RC:C) = Base:5.8/Temporal:0
(AV:N/AC:M/Au:N/C:P/I:P/A:N/E:ND/RL:O/RC:C) = Base:5.8/Temporal:0
(AV:N/AC:M/Au:N/C:P/I:P/A:N/E:ND/RL:O/RC:C) = Base:5.8/Temporal:0
CVE ID:
CVE-2012-0938
CVE-2012-0939
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
TestLink 1.x
Уязвимые версии: , возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "req_spec_id" в сценарии lib/requirements/reqSpecAnalyse.php, lib/requirements/reqSpecPrint.php и lib/requirements/reqSpecView.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

Для успешной эксплуатации уязвимости необходимо иметь привилегии "Requirement view".

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "root_node" и "node" в сценариях lib/ajax/getrequirementnodes.php and lib/ajax/gettprojectnodes.php в функции "display_children()" в lib/ajax/getrequirementnodes.php и lib/ajax/gettprojectnodes.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "cfield_id" в сценарии lib/cfields/cfieldsEdit.php (когда параметр "do_action" равен "edit"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

Для успешной эксплуатации уязвимости необходимо иметь привилегии "Custom field management".

4. Уязвимость существует из-за недостаточной обработки входных данных в параметре "tplan_id" в сценарии lib/plan/planMilestonesEdit.php (когда параметр "doAction" равен "create"), а также в параметре "id" в сценарии lib/plan/planMilestonesEdit.php (когда параметр "doAction" равен "edit"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

Для успешной эксплуатации уязвимости необходимо иметь привилегии "Test Plan planning".

5. Уязвимость существует из-за недостаточной обработки входных данных в параметре "req_spec_id" в сценарии lib/requirements/reqImport.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

Для успешной эксплуатации уязвимости необходимо иметь привилегии "Requirement view" и "Requirement management".

URL производителя: http://www.teamst.org/

Решение: Установите исправление с сайта производителя.



Ссылки: http://archives.neohapsis.com/archives/bugtraq/2012-02/0104.html
http://mantis.testlink.org/view.php?id=4906
или введите имя

CAPTCHA