Множественные уязвимости в Horde Groupware Webmail Edition

Дата публикации:
14.02.2012
Дата изменения:
02.03.2012
Всего просмотров:
2320
Опасность:
Критическая
Наличие исправления:
Да
Количество уязвимостей:
4
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:L/Au:N/C:C/I:C/A:C/E:H/RL:O/RC:C) = Base:10/Temporal:8.7
CVE ID:
CVE-2012-0209
CVE-2012-0791
CVE-2012-0909
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Активная эксплуатация уязвимости
Уязвимые продукты:
Horde Groupware Webmail Edition 1.x
Уязвимые версии: Horde Groupware Webmail Edition 1.x

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю раскрыть важные данные.

1. Уязвимость существует из-за недостаточной обработки входных данных в поле формы электронной почты. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

С подробным описанием уязвимостей можно ознакомиться по адресу: http://www.securitylab.ru/vulnerability/413650.php

2. Уязвимость существует из-за недостаточной обработки входных данных в странице compose и всплывающем окне контактов. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

С подробным описанием уязвимостей можно ознакомиться по адресу: http://www.securitylab.ru/vulnerability/413652.php, № 1

3. Уязвимость существует из-за недостаточной обработки входных данных в почтовых именах IMAP. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

С подробным описанием уязвимостей можно ознакомиться по адресу: http://www.securitylab.ru/vulnerability/413652.php, № 2

Примечание: Уязвимости № 1,2 и 3 распространяются на версии до 1.2.11 4. Уязвимость существует из-за наличия бэкдора в дистрибутиве с продукта. Удаленный пользователь может выполнить произвольный код на целевой системе.

Примечание: Уязвимость распространяется на версии 3.3.12 (загруженные между 15 ноября 2011 года и 7 февраля 2012 года), 1.2.10 (загруженные 9 ноября 2011 года и 7 февраля 2012 года) и 1.2.10.

URL производителя: http://www.horde.org/

Решение: Для устранения уязвимости установите продукт версии 1.2.11 с сайта производителя.

Ссылки: http://lists.horde.org/archives/announce/2012/000750.html
http://lists.horde.org/archives/announce/2012/000751.html
http://git.horde.org/diff.php/groupware/docs/webmail/CHANGES

или введите имя

CAPTCHA