Отказ в обслуживании в Asterisk

Дата публикации:
02.02.2012
Дата изменения:
02.02.2012
Всего просмотров:
789
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2012-0885
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Asterisk 1.x
Asterisk 10.x
Уязвимые версии: Asterisk версии до 10.0.1 и 1.8.8.2

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки при обработке зашифрованных потоков во время переговоров о SRTP видео потоке. Удаленный пользователь может с помощью специально сформированного SDP сообщения вызвать разыменование нулевого указателя и аварийно завершить работу приложения. Для успешной эксплуатации уязвимости требуется, чтобы поддержка видео была отключена и модуль res_srtp был загружен.

URL производителя: www.asterisk.org

Решение: Установите последнюю версию 10.0.1 или 1.8.8.2 с сайта производителя.

Ссылки: http://downloads.asterisk.org/pub/security/AST-2012-001.html

или введите имя

CAPTCHA