Межсайтовый скриптинг в Drupal Managesite Module

Дата публикации:
31.01.2012
Дата изменения:
31.01.2012
Всего просмотров:
687
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Managesite Module 6.x
Уязвимые версии: Drupal Managesite Module версия до 6.x-1.1.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в названии при добавлении или изменении категории. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: drupal.org/project/commerce

Решение: Установите последнюю версию 6.x-1.1. с сайта производителя.

Ссылки: http://drupal.org/node/1417000
http://drupalcode.org/project/managesite.git/blobdiff/7dd99c47d891d482be1430d3c06a5bb0f6c74d85..7051b7e:/managesite.module

или введите имя

CAPTCHA