Межсайтовый скриптинг в WordPress My Calendar

Дата публикации:
30.01.2012
Дата изменения:
30.01.2012
Всего просмотров:
771
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
My Calendar 1.x (plugin for WordPress)
Уязвимые версии: My Calendar plugin for WordPress 1.10.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за неопределенной ошибки при обработке входных данных. Уязвимость существует из-за недостаточной обработки входных данных в URL. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Для успешной эксплуатации уязвимости необходимо чтобы параметр "Display a jumpbox for changing month and year quickly?" был включен.

URL производителя: http://wordpress.org/extend/plugins/my-calendar/

Решение: Установите последнюю версию 1.10.5 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/my-calendar/changelog/
http://plugins.trac.wordpress.org/changeset/490070/my-calendar#file2

или введите имя

CAPTCHA