Переполнение буфера в ActiveFax (ActFax)

Дата публикации:
16.02.2011
Дата изменения:
28.01.2012
Всего просмотров:
1095
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
3
CVSSv2 рейтинг:
(AV:N/AC:L/Au:S/C:C/I:C/A:C/E:F/RL:U/RC:C) = Base:9/Temporal:8.6
(AV:N/AC:L/Au:N/C:C/I:C/A:C/E:U/RL:U/RC:C) = Base:10/Temporal:8.5
(AV:N/AC:L/Au:N/C:C/I:C/A:C/E:F/RL:U/RC:C) = Base:10/Temporal:9.5
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Функциональный эксплоит
Уязвимые продукты:
ActiveFax (ActFax) 4.x
Уязвимые версии: ActiveFax (ActFax) версии 4.25 Build 0221 и 4.27 Build 0223, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки проверки границ данных при обработке команды FTP "RETR". Удаленный пользователь может передать команду "RETR", содержащую слишком длинный параметр, вызвать переполнение буфера в стеке и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки границ данных в LPD/LPR сервере. Удаленный пользователь может с помощью специально сформированной команды вызвать переполнение буфера в стеке и выполнить произвольный код на целевой системе.

3. Уязвимость существует из-за ошибки проверки границ данных при обработке команды FTP "USER". Удаленный пользователь может отправить FTP серверу команду "USER", содержащую слишком длинную строку, вызвать переполнение буфера в стеке и выполнить произвольный код на целевой системе.

URL производителя: www.actfax.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: ActFax Server FTP RETR Remote Buffer Overflow Exploit
ActFax Server (LPD/LPR) Remote Buffer Overflow Exploit
http://www.exploit-db.com/exploits/16177/
http://www.exploit-db.com/exploits/16176/
Журнал изменений: 28.01.2012
Добавлен экслоит.

или введите имя

CAPTCHA