Множественные уязвимости в ядре Linux

Дата публикации:
14.07.2011
Дата изменения:
08.02.2012
Всего просмотров:
444
Опасность:
Низкая
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:L/AC:L/Au:N/C:N/I:N/A:C/E:U/RL:W/RC:C) = Base:4.9/Temporal:4
(AV:L/AC:L/Au:N/C:N/I:N/A:C/E:U/RL:W/RC:C) = Base:4.9/Temporal:4
CVE ID:
CVE-2011-2689
CVE-2011-2695
Вектор эксплуатации:
Локальная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Linux Kernel 2.6.x
Уязвимые версии: Linux kernel 2.6.x

Описание:
Обнаруженные уязвимости позволяют локальному пользователю вызвать отказ в обслуживании системы.

1. Уязвимость существует из-за ошибки в функции gfs2_fallocate() в файле fs/gfs2/file.c при проверке выделяемой памяти. Локальный пользователь может вызвать отказ в обслуживании системы.

2. Уязвимость существует из-за ошибки в реализации файловой системы ext4 при обработке записи в последний блок файла в extent формате. Локальный пользователь может вызвать отказ в обслуживании ядра.

URL производителя: www.kernel.org

Решение: Установите исправление из GIT репозитория производителя.

Ссылки: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=6905d9e4dda6112f007e9090bca80507da158e63
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=f17722f917b2f21497deb6edc62fb1683daa08e6
Журнал изменений: 08.02.2012
Незначительные изменения.

или введите имя

CAPTCHA