SQL-инъекция в Shortcode

Дата публикации:
06.10.2011
Всего просмотров:
974
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:6.4/Temporal:4.7
CVE ID:
CVE-2011-4646
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress WP-PostRatings Plugin 1.x
Уязвимые версии: WP-PostRatings plugin for WordPress 1.61 и предыдущие версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в атрибуте "id" в сценарии wp-content/plugins/wp-postratings/wp-postratings.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

Решение:Установите последнюю версию 1.62 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/wp-postratings/changelog/
http://plugins.trac.wordpress.org/changeset/430970/wp-postratings/trunk/wp-postratings.php

или введите имя

CAPTCHA