Межсайтовый скриптинг в WordPress WP Ajax Recent Posts Plugin

Дата публикации:
27.04.2011
Всего просмотров:
630
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C) = Base:4.3/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress WP Ajax Recent Posts Plugin 1.x
Уязвимые версии: WordPress WP Ajax Recent Posts Plugin 1.0.1 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "number" в parameter in index.php (когда параметр "action" равен "wpAjaxRecentPosts") в wp-content/plugins/wp-ajax-recent-posts/func/function.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.htbridge.ch/advisory/xss_in_wp_ajax_recent_posts_wordpress_plugin.html

или введите имя

CAPTCHA