Межсайтовый скриптинг в CGI:IRC

Дата публикации:
10.02.2011
Всего просмотров:
643
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
CVE-2011-0050
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CGI:IRC 0.x
Уязвимые версии: CGI:IRC версии до 0.5.10

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "R" в parameter in the "nonjs" interface (interfaces/nonjs.pm). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Решение: Установите последнюю версию с сайта производителя.

Ссылки: http://sourceforge.net/mailarchive/message.php

или введите имя

CAPTCHA