Отказ в обслуживании в Wireshark

Дата публикации:
30.06.2011
Дата изменения:
20.01.2012
Всего просмотров:
801
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2011-2597
CVE-2011-2698
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Wireshark 1.x
Уязвимые версии: Wireshark версии до 1.2.18, 1.4.8 и 1.6.1

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании приложения.

1. Уязвимость существует из-за ошибки в обработчике Lucent/Ascend файлов. Удаленный пользователь может с помощью специально сформированных пакетов вызвать зацикливание приложения. Уязвимость распространяется на версии 1.2.0 по 1.2.17, 1.4.0 по 1.4.7 и 1.6.0.

2. Уязвимость существует из-за ошибки бесконечной рекурсии в функции elem_cell_id_list() в файле epan/dissectors/packet-ansi_a.c. Удаленный пользователь может с помощью специально сформированного MAP пакета вызвать переполнение стека и аварийно завершить работу приложения.

URL производителя: www.wireshark.org

Решение: Установите последнюю версию 1.2.18, 1.4.8 или 1.6.1. с сайта производителя.

Ссылки: http://www.wireshark.org/security/wnpa-sec-2011-09.html
http://www.wireshark.org/security/wnpa-sec-2011-10.html
http://www.wireshark.org/security/wnpa-sec-2011-11.html
http://www.wireshark.org/docs/relnotes/wireshark-1.4.8.html
http://www.wireshark.org/docs/relnotes/wireshark-1.6.1.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=6044
Журнал изменений: 20.01.2012
Добавлены CVSS метрики.

или введите имя

CAPTCHA