Межсайтовый скриптинг в ATutor

Дата публикации:
17.01.2012
Дата изменения:
17.01.2012
Всего просмотров:
1822
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:P/RL:U/RC:C) = Base:4.3/Temporal:3.9
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
ATutor 2.x
Уязвимые версии: ATutor 2.0.3, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в URL в сценариях login.php, search.php, password_reminder.php, browse.php, registration.php, about.php, themes/default/tile_search/index.tmpl.php и themes/default/social/basic_profile.tmpl.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: atutor.ca/atutor/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.darksecurity.de/advisories/2012/SSCHADV2012-002.txt

или введите имя

CAPTCHA