Межсайтовый скриптинг в KnowledgeTree

Дата публикации:
12.01.2012
Дата изменения:
12.01.2012
Всего просмотров:
761
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
KnowledgeTree Open Source 3.x
Уязвимые версии: KnowledgeTree 3.7.0.2, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в URL в сценарии login.php, admin.php, и preferences.php в config/dmsDefaults.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://www.ktdms.com/products/knowledgetree/index.html

Решение: Установите исправление с сайта производителя.

Ссылки: http://www.knowledgetree.org/Security_advisory:_URL_Manipulation
https://www.htbridge.ch/advisory/multiple_vulnerabilities_in_knowledgetree_community_edition.html

или введите имя

CAPTCHA