Множественные уязвимости в Apache Tomcat

Дата публикации:
26.09.2011
Всего просмотров:
1533
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:L/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:O/RC:C) = Base:4.6/Temporal:3.4
(AV:L/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:O/RC:C) = Base:2.1/Temporal:1.6
CVE ID:
CVE-2011-2526
Вектор эксплуатации:
Локальная
Воздействие:
Отказ в обслуживании
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache Tomcat 5.x
Apache Tomcat 6.x
Apache Tomcat 7.x
Уязвимые версии:
Apache Tomcat версий до 5.5.34
Apache Tomcat версий до 6.0.33
Apache Tomcat версий до 7.0.19

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти ограничения безопасности на целевой системе.

1. Уязвимость существует из-за некорректной проверки атрибутов запроса на отправку файлов в менеджере безопасности. Удаленный пользователь может с помощью специально сформированного приложения обойти определенные ограничения безопасности.

2. Уязвимость существует из-за некорректной обработки запросов на отправку файлов. Удаленный пользователь может с помощью специально сформированного запроса с недействительной точкой запуска и прерывания вызвать аварийное завершение работы JVM.

Примечание: Для успешной эксплуатации уязвимости требует запуск специально сформированного приложения, а менеджер безопасности и HTTP NIO или HTTP APR должны работать с включенной функцией отправки файлов.

URL производителя: http://jakarta.apache.org/tomcat/

Решение: Для устранения уязвимости установите продукт версии 5.5.34, 6.0.33, или 7.0.19 с сайта производителя.

Ссылки: http://tomcat.apache.org/security-5.html#To_be_fixed_in_Apache_Tomcat_5.5.34_(not_yet_released)
http://tomcat.apache.org/security-6.html#To_be_fixed_in_Apache_Tomcat_6.0.33_(not_yet_released)
http://tomcat.apache.org/tomcat-7.0-doc/changelog.html#Tomcat%207.0.19%20%28markt%29

или введите имя

CAPTCHA