Межсайтовый скриптинг в WordPress TheCartPress Plugin

Дата публикации:
09.01.2012
Дата изменения:
09.01.2012
Всего просмотров:
1361
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:P/RL:O/RC:C) = Base:4.3/Temporal:3.4
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
WordPress TheCartPress Plugin 1.x
Уязвимые версии: TheCartPress (плагин к WordPress) 1.1.6 от 31.12.2011 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре tcp_name_post_1 в сценарии admin/OptionsPostsList.php, когда параметр tcp_options_posts_update установлен и параметр tcp_post_ids[] равен 1. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://wordpress.org/extend/plugins/thecartpress/

Решение: Установите последнюю версию 1.1.6 после 31.12.2011 с сайта производителя.

Ссылки: http://plugins.trac.wordpress.org/changeset/482746/thecartpress
http://packetstormsecurity.org/files/108272/wpcartpress-xss.txt

или введите имя

CAPTCHA