Межсайтовый скриптинг в WordPress

Дата публикации:
09.01.2012
Дата изменения:
09.01.2012
Всего просмотров:
1978
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:O/RC:C) = Base:5/Temporal:3.9
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
WordPress 3.x
Уязвимые версии: WordPress 3.3

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в URL в функции wp_guess_url() (файл wp-includes/functions.php) в сценарии wp-comments-post.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: wordpress.org

Решение: Установите последнюю версию 3.3.1 с сайта производителя.

Ссылки: http://wordpress.org/news/2012/01/wordpress-3-3-1/
http://oldmanlab.blogspot.com/2012/01/wordpress-33-xss-vulnerability.html

или введите имя

CAPTCHA