Межсайтовый скриптинг в phpMyAdmin

Дата публикации:
23.12.2011
Дата изменения:
23.12.2011
Всего просмотров:
1066
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:6.4/Temporal:4.7
CVE ID:
CVE-2011-4782
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpMyAdmin 3.x
Уязвимые версии: phpMyAdmin все версии до 3.4.9.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "$host". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Примечание: Для успешной эксплуатации уязвимости необходимо чтобы конфигурация каталога была открыта для записи.

URL производителя: http://www.phpmyadmin.net/

Решение: Установите последнюю версию 3.4.9 с сайта производителя.

Ссылки: http://www.phpmyadmin.net/home_page/security/PMASA-2011-19.php

или введите имя

CAPTCHA