Межсайтовый скриптинг в epesi BIM

Дата публикации:
22.12.2011
Дата изменения:
22.12.2011
Всего просмотров:
1102
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
3
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:O/RC:C) = Base:5/Temporal:3.9
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:O/RC:C) = Base:5/Temporal:3.9
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:O/RC:C) = Base:5/Temporal:3.9
CVE ID:
Нет данных
Вектор эксплуатации:
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
epesi BIM 1.x
Уязвимые версии: epesi BIM 1.2.0-rev8154, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за неопределенной ошибки при обработке входных данных. 1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "dir_atual" в сценарии admin/phpfm.php (когда параметр "frame" равен "3"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/admin/phpfm.php?frame=3&dir_atual=%3Cscript%3Ealert%28123%29;%3C/script%3E

2. Уязвимость существует из-за недостаточной обработки входных данных в URL в сценарии admin/themeup.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:
http://[host]/admin/themeup.php/%22%3E%3Cscript%3Ealert%28123%29;%3C/script%3E

Для успешной эксплуатации уязвимости необходимо, чтобы параметр "AcceptPathInfo" был равен "on" или "default".

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "msg" в сценарии admin/wfb.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:
http://[host]/admin/wfb.php?msg=%3Cscript%3Ealert%28document.cookie%29;%3C/script%3E

URL производителя: http://www.epesibim.com/

Решение: Установите последнюю версию 1.2.2 rev 8605 с сайта производителя.

Ссылки: https://www.htbridge.ch/advisory/multiple_vulnerabilities_in_epesi_bim.html
http://forum.epesibim.com/viewtopic.php?f=6&t=751

или введите имя

CAPTCHA