Межсайтовый скриптинг в CodeIgniter

Дата публикации:
30.11.2011
Дата изменения:
30.11.2011
Всего просмотров:
2389
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CodeIgniter 2.x
Уязвимые версии: CodeIgniter все версии до 2.0.3.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за неопределенной ошибки при обработке входных данных. Уязвимость существует из-за недостаточной обработки входных данных в функции "xss_clean()". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://codeigniter.com/

Решение: Установите последнюю версию 2.1.0 с сайта производителя.

Ссылки: http://codeigniter.com/user_guide/changelog.html
http://www.ventuneac.net/security-advisories/MVSA-11-013

или введите имя

CAPTCHA