Обход ограничений безопасности в Oracle Mojarra

Дата публикации:
29.11.2011
Дата изменения:
29.11.2011
Всего просмотров:
1463
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:O/RC:C) = Base:7.5/Temporal:5.5
CVE ID:
CVE-2011-4358
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Oracle Mojarra 2.x
Уязвимые версии: Oracle Mojarra 2.x

Описание:
Уязвимость позволяет удаленному пользователю обойти некоторые ограничения безопасности.

Уязвимость существует из-за ошибки при обработке параметров в Java Bean, которая может привести к тому, что определенные параметры будут восприняты, как выражения EL.

Примечание: Успешная эксплуатация уязвимости требует, чтобы includeViewParameters было установлено на true.

URL производителя: http://javaserverfaces.java.net/

Решение: Установите обновление с сайта производителя.

Ссылки: http://java.net/jira/browse/JAVASERVERFACES-2247

или введите имя

CAPTCHA