Межсайтовый скриптинг в WP e-Commerce

Дата публикации:
22.11.2011
Дата изменения:
22.11.2011
Всего просмотров:
2107
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress WP e-Commerce Plugin 3.x
Уязвимые версии: WP e-Commerce plugin for WordPress 3.8.7.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "custom_text" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://getshopped.org/

Решение: Установите последнюю версию 3.8.7.2 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/wp-e-commerce/changelog/
http://plugins.trac.wordpress.org/changeset?reponame=&new=463447%40wp-e-commerce&old=463446%40wp-e-commerce

или введите имя

CAPTCHA