SQL-инъекция в WordPress AdRotate Plugin

Дата публикации:
15.11.2011
Дата изменения:
15.11.2011
Всего просмотров:
2661
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:U/RC:C) = Base:6.4/Temporal:5.4
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
AdRotate 3.x (plugin for WordPress)
Уязвимые версии: AdRotate plugin for WordPress 3.6.6, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "track" в сценарии wp-content/plugins/adrotate/adrotate-out.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: http://wordpress.org/extend/plugins/adrotate/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://unconciousmind.blogspot.com/2011/11/wordpress-adrotate-plugin-366-sql.html

или введите имя

CAPTCHA