Повышений привилегий в Apache HTTP Server

Дата публикации:
02.11.2011
Дата изменения:
21.02.2012
Всего просмотров:
1704
Опасность:
Низкая
Наличие исправления:
Частично
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:L/AC:L/Au:N/C:C/I:C/A:C/E:P/RL:W/RC:C) = Base:7.2/Temporal:6.2
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Отказ в обслуживании
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
Apache 2.0.x
Apache 2.2.x
Уязвимые версии: Apache HTTP Server 2.0.64 и 2.2.21, возможно другие версии.

Описание:
Локальный пользователь может вызвать отказ в обслуживании и повысить свои привилегии на системе.

Целочисленное переполнение обнаружено в функции ap_pregsub() в файле server/utils.c. Локальный пользователь может с помощью специально сформированного .htaccess файла вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя:

Решение: Установите исправление, если оно доступно, с сайта производителя.

Ссылки:
http://www.halfdog.net/Security/2011/ApacheModSetEnvIfIntegerOverflow/
http://www.halfdog.net/Security/2011/ApacheModSetEnvIfIntegerOverflow/DemoExploit.html
Журнал изменений: 14.11.2011
Изменена секция "Решение". 21.02.2012
Изменены секции "Решение" и "Наличие исправления".

или введите имя

CAPTCHA