Межсайтовый скриптинг в Drupal String Overrides

Дата публикации:
11.11.2011
Дата изменения:
11.11.2011
Всего просмотров:
946
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C) = Base:5/Temporal:4.3
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C) = Base:5/Temporal:4.3
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal String Overrides Module 6.x
Уязвимые версии: String Overrides module for Drupal 6.x-1.8, возможно более ранние версии.

Описание:
Уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "string[0][replacement]" в сценарии index.php (когда параметр "q" равен "admin/settings/stringoverrides"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в сценарии index.php (когда параметр "q" равен "admin/settings/stringoverrides/import"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://drupal.org/project/stringoverrides

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.madirish.net/content/drupal-string-overrides-module-xss

или введите имя

CAPTCHA