Межсайтовый скриптинг в Serendipity

Дата публикации:
03.11.2011
Дата изменения:
03.11.2011
Всего просмотров:
1260
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Serendipity 1.x
Уязвимые версии: Serendipity 1.5.5, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "serendipity[filter][bp.ALT]" в сценарии serendipity_admin_image_selector.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://www.s9y.org/

Решение: Установите последнюю версию 1.6 с сайта производителя.

Ссылки: http://blog.s9y.org/archives/233-Serendipity-1.6-released.html
https://github.com/s9y/Serendipity/commit/1f037b462761cd592b90541ce4dfda2518ad4711
http://www.rul3z.de/advisories/SSCHADV2011-015.txt

или введите имя

CAPTCHA