SQL-инъекция в WordPress WP-Polls

Дата публикации:
30.09.2011
Всего просмотров:
4182
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:6.4/Temporal:4.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress WP-Polls Plugin 2.x
Уязвимые версии: WordPress WP-Polls 2.50 и 2.61, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "id" в сценарии wp-content/plugins/wp-polls/wp-polls.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: http://wordpress.org/extend/plugins/wp-polls/

Решение: Установите последнюю версию 2.62 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/wp-polls/changelog/
http://plugins.trac.wordpress.org/changeset/430968/wp-polls/trunk/wp-polls.php?old=355075&old_path=wp-polls%2Ftrunk%2Fwp-polls.php

или введите имя

CAPTCHA