Множественные уязвимости в WordPress teachPress Plugin

Дата публикации:
14.10.2011
Дата изменения:
14.10.2011
Всего просмотров:
976
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress teachPress Plugin 2.x
Уязвимые версии: WordPress teachPress Plugin 2.3.2, возможно другие версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю раскрыть важные данные на целевой системе.

1. Уязвимость существует из-за недостаточной обработки входных данных параметра «root» в сценарии wp-content/plugins/teachpress/feed.php. Удаленный пользователь может с помощью специально сформированных запросов получить доступ к файлам на целевой системе.

2. Уязвимость существует из-за недостаточной обработки входных данных параметра «root» в сценарии wp-content/plugins/teachpress/export.php (когда "lvs_ID" и "type" настроены). Удаленный пользователь может с помощью специально сформированных запросов получить доступ к файлам на целевой системе.

URL производителя: http://wordpress.org/extend/plugins/teachpress/

Ссылки: http://plugins.trac.wordpress.org/changeset/405672/teachpress/trunk/feed.php?old=340149&old_path=teachpress%2Ftrunk%2Ffeed.php
http://plugins.trac.wordpress.org/changeset/405672/teachpress/trunk/export.php?old=340149&old_path=teachpress%2Ftrunk%2Fexport.php

или введите имя

CAPTCHA