Выполнение произвольных команд в WordPress Light Post Plugin

Дата публикации:
13.10.2011
Дата изменения:
13.10.2011
Всего просмотров:
1168
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:C/I:C/A:C/E:U/RL:O/RC:C) = Base:10/Temporal:7.4
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Light Post Plugin 1.x
Уязвимые версии: WordPress Light Post Plugin 1.4, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной проверки подлинности входных данных в параметре abspath в сценарии wp-content/plugins/light-post/wp-light-post.php. Удаленный пользователь может с помощью специально сформированного URL подключить и выполнить произвольный PHP сценарий на целевой системе.

URL производителя: wordpress.org/extend/plugins/light-post/

Решение: Установите последнюю версию 1.5 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/light-post/changelog/
http://plugins.trac.wordpress.org/changeset/437217/light-post/trunk/wp-light-post.php?old=416259&old_path=light-post%2Ftrunk%2Fwp-light-post.php

или введите имя

CAPTCHA