Уязвимость при обработке DMA запросов в Xen

Дата публикации:
15.08.2011
Дата изменения:
27.09.2011
Всего просмотров:
865
Опасность:
Низкая
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:L/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:W/RC:C) = Base:2.1/Temporal:1.7
CVE ID:
CVE-2011-3131
Вектор эксплуатации:
Локальная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Xen 4.x
Xen 3.x
Уязвимые версии: Xen 3.x, 4.1.1, возможно другие версии.

Описание:
Уязвимость позволяет локальному пользователю вызвать отказ в обслуживании.

Уязвимость существует из-за некорректного ограничения фальшивых DMA запросов к PCI/PCIE устройствам, принадлежащим виртуальной машине. Локальный пользователь может вызвать ошибки IOMMU и потребить большое количество процессорного времени.

URL производителя: www.xen.org/products/xenhyp.html

Решение: Установите исправление из Mercurial репозитория производителя.

Ссылки: http://lists.xensource.com/archives/html/xen-devel/2011-06/msg01106.html
http://xenbits.xen.org/hg/staging/xen-4.1-testing.hg/rev/84e3706df07a
http://lists.xensource.com/archives/html/xen-devel/2011-08/msg00450.html
Журнал изменений: 27.09.2011
Изменена секция "Программа", добавлена информация об уязвимости в версиях Xen 3.x

или введите имя

CAPTCHA