Межсайтовый скриптинг в WordPress WP e-Commerce Plugin

Дата публикации:
05.08.2011
Дата изменения:
05.08.2011
Всего просмотров:
2330
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C) = Base:5/Temporal:4.3
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress WP e-Commerce Plugin 3.x
Уязвимые версии: WordPress WP e-Commerce Plugin 3.8.6, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "cart_messages[]" в сценарии wp-content/plugins/wp-e-commerce/wpsc-theme/wpsc-cart_widget.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: getshopped.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.htbridge.ch/advisory/xss_in_wp_e_commerce.html

или введите имя

CAPTCHA