Переполнение буфера в FreeBSD

Дата публикации:
04.04.2011
Дата изменения:
04.04.2011
Всего просмотров:
2889
Опасность:
Средняя
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:N/A:C/E:P/RL:W/RC:C) = Base:7.8/Temporal:6.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
FreeBSD 7.1
FreeBSD 7.2
FreeBSD 7.3
FreeBSD 8.0
FreeBSD 8.1
Уязвимые версии: FreeBSD 7.1, 7.1, 8.0, 8.1

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании.

Уязвимость существует из-за ошибки при обработке определенных IPComp (IP Payload Compression Protocol) данных. Удаленный пользователь может с помощью специально сформированного пакета вызвать переполнение стека и аварийно завершить работу системы. Уязвимость относится к:
www.securitylab.ru/vulnerability/405287.php

URL производителя: www.freebsd.org

Решение: Установите исправление из CVS репозитория производителя.

Ссылки: IPComp Encapsulation Pre-auth Kernel Memory Corruption PoC
http://www.openwall.com/lists/oss-security/2011/04/01/1

или введите имя

CAPTCHA