Межсайтовый скриптинг в WordPress Rating-Widget Plugin

Дата публикации:
18.03.2011
Дата изменения:
18.03.2011
Всего просмотров:
2924
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:U/RC:C) = Base:5/Temporal:4.5
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
WordPress Rating-Widget Plugin 1.x
Уязвимые версии: WordPress Rating-Widget Plugin 1.3.2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "selected_key" в сценарии wp-content/plugins/rating-widget/view/availability_options.php, в параметре "vars[type]" в сценарии wp-content/plugins/rating-widget/view/rating.php, и в параметре "rw_form_hidden_field_name" в сценарии wp-content/plugins/rating-widget/view/save.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: www.wordpress.org/extend/plugins/rating-widget

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.htbridge.ch/advisory/xss_in_rating_widget_wordpress_plugin.html
http://www.htbridge.ch/advisory/xss_in_rating_widget_wordpress_plugin_1.html
http://www.htbridge.ch/advisory/xss_in_rating_widget_wordpress_plugin_2.html

или введите имя

CAPTCHA