Межсайтовый скриптинг в WordPress SodaHead Polls Plugin

Дата публикации:
18.03.2011
Дата изменения:
18.03.2011
Всего просмотров:
1612
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:O/RC:C) = Base:5/Temporal:3.9
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
WordPress SodaHead Polls Plugin 2.x
Уязвимые версии: WordPress SodaHead Polls Plugin 2.0.2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "customize" в сценарии wp-content/plugins/sodahead-polls/poll.php и в параметре "poll_id" в сценарии wp-content/plugins/sodahead-polls/customizer.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: wordpress.org/extend/plugins/sodahead-polls/

Решение: Установите последнюю версию 2.0.4 с сайта производителя.

Ссылки: http://wordpress.org/extend/plugins/sodahead-polls/changelog/
http://www.htbridge.ch/advisory/xss_in_sodahead_polls_wordpress_plugin.html
http://www.htbridge.ch/advisory/xss_in_sodahead_polls_wordpress_plugin_1.html

или введите имя

CAPTCHA