Множественные уязвимости в Pointter PHP Content Management System

Дата публикации:
17.03.2011
Дата изменения:
17.03.2011
Всего просмотров:
1393
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:U/RC:C) = Base:5/Temporal:4.5
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:P/RL:U/RC:C) = Base:6.4/Temporal:5.8
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
Pointter PHP Content Management System 1.x
Уязвимые версии: Pointter PHP Content Management System 1.2, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL запросы в базе данных.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "category" в сценарии admin/functions/createcategory.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "onoff", "pos", "count", "boxname", "tonoff", "tpos", "tname", "monoff", "mpos", "mname", "nonoff", "npos", "nname", "memonoff", "mempos", "memname", "searchonoff", "searchname" и "mail" в сценарии admin/functions/editsettings.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

URL производителя: www.pointter.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.zeroscience.mk/en/vulnerabilities/ZSL-2011-5002.php

или введите имя

CAPTCHA