Переполнение буфера в IBM WebSphere MQ

Дата публикации:
17.01.2011
Дата изменения:
17.01.2011
Всего просмотров:
1225
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:A/AC:L/Au:S/C:P/I:P/A:P/E:U/RL:O/RC:C) = Base:5.2/Temporal:3.8
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WebSphere MQ 6.x
WebSphere MQ 7.x
Уязвимые версии: IBM WebSphere MQ версии до 6.0.2.11 и 7.0.1.5.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки при обработке сообщений в очереди. Удаленный пользователь может внедрить специально сформированное сообщение в очередь, вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www-01.ibm.com/software/integration/wmq/

Решение: Установите исправление APAR IZ81294 с сайта производителя.

Ссылки: https://www-304.ibm.com/support/docview.wss?uid=swg21254675
http://xforce.iss.net/xforce/xfdb/64550

или введите имя

CAPTCHA