Отказ в обслуживании в функции cu_rrd_create_file() в collectd

Дата публикации:
30.11.2010
Дата изменения:
30.11.2010
Всего просмотров:
1460
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:A/AC:L/Au:N/C:N/I:N/A:C/E:U/RL:O/RC:C) = Base:6.1/Temporal:4.5
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
collectd 4.x
Уязвимые версии: collectd версии до 4.9.4 и 4.10.2

Описание:
Удаленный пользователь может вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки утверждения в функции cu_rrd_create_file() в файле src/utils_rrdcreate.c. Удаленный пользователь может с помощью специально сформированного сетевого пакета вызвать отказ в обслуживании посредством RRDtool и RRDCacheD плагинов.

URL производителя: collectd.org

Решение: Установите последнюю версию 4.9.4 или 4.10.2 с сайта производителя.

Ссылки: http://collectd.org/news.shtml#news86
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=605092

или введите имя

CAPTCHA