Некорректная обработка переменой окружения LD_LIBRARY_PATH в GNOME Shell

Дата публикации:
18.11.2010
Дата изменения:
18.11.2010
Всего просмотров:
2244
Опасность:
Низкая
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:L/AC:L/Au:N/C:C/I:C/A:P/E:U/RL:W/RC:C) = Base:6.8/Temporal:5.5
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GNOME Shell 2.x
Уязвимые версии: GNOME Shell 2.31.5, возможно другие версии.

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе.

Уязвимость существует из-за того, что сценарий gnome-shell устанавливает некорректным образом переменную окружения LD_LIBRARY_PATH. Злоумышленник может обманом заставить пользователя запустить сценарий из директории, в которой находится вредоносное приложение, и выполнить произвольный код на системе с привилегиями текущего пользователя.

URL производителя: live.gnome.org/GnomeShell

Решение: Установите исправление из GIT репозитория производителя.

Ссылки: https://bugzilla.gnome.org/show_bug.cgi?id=631004
http://git.gnome.org/browse/gnome-shell/commit/?id=c6eb2761c719af47248badb2187866ffaff6e671

или введите имя

CAPTCHA