Межсайтовый скриптинг в iWiccle

Дата публикации:
26.10.2010
Дата изменения:
26.10.2010
Всего просмотров:
1185
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
iWiccle 1.x
Уязвимые версии: iWiccle 1.2.1.1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "post_name", "post_text", "post_tag" и "post_member_name", когда параметр "show" равен "post_search" и параметр "module" равен "articles", и в параметрах "member_username" и "member_tags", когда параметр "module" равен "members" и параметр "show" равен"member_search", в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.wiccle.com

Решение: Установите последнюю версию 1.3.0 с сайта производителя.

Ссылки: http://www.wiccle.com/news/backstage_news/iwiccle/post/iwiccle_cms_community_builder_130_releas
http://secpod.org/blog/?p=130

или введите имя

CAPTCHA