Разыменование нулевого указателя в Kerberos GSS-API

Дата публикации:
19.05.2010
Дата изменения:
19.10.2010
Всего просмотров:
1166
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:S/C:N/I:N/A:C/E:U/RL:O/RC:C) = Base:6.8/Temporal:5
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Kerberos 5.x
Уязвимые версии: Kerberos krb5-1.8.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки разыменования нулевого указателя при обработке определенных Kerberos AP-REQ аутентификаторов. Удаленный пользователь может с помощью специально сформированного аутентификатора AP-REQ, не содержащего поле контрольной суммы, аварийно завершить работу kadmind или других приложений, использующих библиотеку GSS-API.

URL производителя: web.mit.edu/kerberos/www/

Решение: Установите последнюю версию 1.7 или 1.8.2 с сайта производителя.

Ссылки: http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2010-005.txt
Журнал изменений: 19.10.2010
Изменена секция "Решение".

или введите имя

CAPTCHA