Множественные уязвимости в Entrans

Дата публикации:
27.09.2010
Дата изменения:
27.09.2010
Всего просмотров:
1034
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
6
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:O/RC:C) = Base:5/Temporal:3.9
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:O/RC:C) = Base:5/Temporal:3.9
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:O/RC:C) = Base:5/Temporal:3.9
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:P/RL:O/RC:C) = Base:6.4/Temporal:5
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:P/RL:O/RC:C) = Base:6.4/Temporal:5
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:P/RL:O/RC:C) = Base:6.4/Temporal:5
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
Entrans 0.x
Уязвимые версии: Entrans 0.3.2, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "query" в сценарии search.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "edit" в сценарии list.php, когда установлен параметр "category". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "query_lookup" в сценарии lookup.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

4. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "parent_id" и "root" в сценарии main.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

5. Уязвимость существует из-за недостаточной обработки входных данных в параметре "query" в сценарии search.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

6. Уязвимость существует из-за недостаточной обработки входных данных в параметре "query_lookup" в сценарии lookup.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

URL производителя: sourceforge.net/projects/entrans/

Решение: Установите последнюю версию 0.3.3 с сайта производителя.

Ссылки: http://sourceforge.net/mailarchive/forum.php?thread_name=4C8F5875.1020400%40users.sourceforge.net&forum_name=entrans-users
http://www.htbridge.ch/advisory/xss_vulnerability_in_entrans.html
http://www.htbridge.ch/advisory/sql_injection_vulnerability_in_entrans.html
http://www.htbridge.ch/advisory/sql_injection_vulnerability_in_entrans_1.html

или введите имя

CAPTCHA