Множественные уязвимости в Adobe Illustrator

Дата публикации:
03.12.2009
Дата изменения:
02.09.2010
Всего просмотров:
1007
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:C/I:C/A:C/E:P/RL:O/RC:C) = Base:10/Temporal:7.8
(AV:N/AC:L/Au:N/C:C/I:C/A:C/E:P/RL:O/RC:C) = Base:10/Temporal:7.8
CVE ID:
CVE-2009-3952
CVE-2009-4195
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
Adobe Illustrator CS3
Adobe Illustrator CS4
Уязвимые версии: Adobe Illustrator CS4 14.0.0, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки при обработке Encapsulated Postscript Files (.eps) файлов. Удаленный пользователь может с помощью специально сформированного .eps файла вызвать повреждение памяти и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки границ данных при обработке Encapsulated Postscript Files (.eps) файлов. Удаленный пользователь может с помощью специально сформированного .eps файла вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.adobe.com

Решение: Установите исправление с сайта производителя.

Ссылки: APSA09-06: Security Advisory for Adobe Illustrator CS4 and Adobe Illustrator CS3
APSB10-01: Security updates available for Adobe Illustrator CS4 and CS3
Secunia Research: Adobe Illustrator Encapsulated Postscript Parsing Vulnerability
http://retrogod.altervista.org/9sg_adobe_illuso.html
Журнал изменений: 08.01.2010
Изменено название уведомления, добавлено уязвимость #2, изменена секция «Решение». 02.09.2010
Незначительные изменения.

или введите имя

CAPTCHA