Межсайтовый скриптинг в e107

Дата публикации:
25.08.2010
Дата изменения:
25.08.2010
Всего просмотров:
8778
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:S/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4/Temporal:3
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
e107 0.x
Уязвимые версии: e107 версии до 0.7.23

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "submitnews_title" в сценарии submitnews.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий. Удаленный пользователь может произвести CSRF нападение и создать произвольные учетные записи пользователей.

URL производителя: e107.org

Решение: Установите последнюю версию 0.7.23 с сайта производителя.

Ссылки: http://e107.org/comment.php?comment.news.872
http://www.madirish.net/?article=471

или введите имя

CAPTCHA