Множественные уязвимости в OpenLDAP

Дата публикации:
22.07.2010
Дата изменения:
22.07.2010
Всего просмотров:
1528
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:A/AC:M/Au:S/C:C/I:C/A:C/E:U/RL:O/RC:C) = Base:7.4/Temporal:5.5
(AV:A/AC:M/Au:S/C:N/I:N/A:C/E:U/RL:O/RC:C) = Base:5.2/Temporal:3.8
CVE ID:
CVE-2010-0211
CVE-2010-0212
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenLDAP 2.4.x
Уязвимые версии: OpenLDAP 2.4.22, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимость существует из-за того, что функция slap_modrdn2mods() файла servers/slapd/modrdn.c не проверяет возвращаемое значение функцией smr_normalize(). Удаленный пользователь может с помощью LDAP "modrdn" запроса, содержащего специально сформированную "rdn" строку, спровоцировать освобождение неинициализированного указателя и вызвать повреждение памяти.

2. Уязвимость существует из-за ошибки при обработке LDAP "modrdn" запросов. Удаленный пользователь может с помощью специально сформированной "rdn" строки вызвать разыменование нулевого указателя в функции IA5StringNormalize() в файле servers/slapd/schema_init.c и аварийно завершить работу службы.

URL производителя: www.openldap.org

Решение: Установите последнюю версию 2.4.23 с сайта производителя.

Ссылки: http://www.openldap.org/its/index.cgi/Software%20Bugs?id=6570

или введите имя

CAPTCHA