Межсайтовый скриптинг в Paste

Дата публикации:
01.07.2010
Дата изменения:
01.07.2010
Всего просмотров:
910
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Paste 1.x (пакет к Python)
Уязвимые версии: Paste (пакет к Python) версии до 1.7.4

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в URL. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: pythonpaste.org

Решение: Установите последнюю версию 1.7.4 с сайта производителя.

Ссылки: http://groups.google.com/group/paste-users/browse_thread/thread/3b3fff3dadd0b1e5#
http://bitbucket.org/ianb/paste/changeset/fcae59df8b56

или введите имя

CAPTCHA