Обход ограничений безопасности в ext4_fallocate() в ядре Linux

Дата публикации:
05.06.2010
Дата изменения:
05.06.2010
Всего просмотров:
1615
Опасность:
Низкая
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:L/AC:L/Au:N/C:N/I:P/A:P/E:U/RL:W/RC:C) = Base:3.6/Temporal:2.9
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Linux Kernel 2.6.x
Уязвимые версии: Linux kernel версии до 2.6.35-rc1

Описание:
Уязвимость позволяет локальному пользователю обойти некоторые ограничения безопасности.

Уязвимость существует из-за того, что функция ext4_fallocate() в файле fs/ext4/extents.c некорректно сравнивает размер файла с установленным значением "RLIMIT_FSIZE". Локальный пользователь может с помощью функции posix_fallocate() создать файлы большего размера, чем разрешено в системных настройках.

URL производителя: www.kernel.org

Решение: Установите последнюю версию 2.6.35-rc1 с сайта производителя.

Ссылки: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=6d19c42b7cf81c39632b6d4dbc514e8449bcd346

или введите имя

CAPTCHA