Ошибка завышения на единицу в OPIE

Дата публикации:
28.05.2010
Дата изменения:
28.05.2010
Всего просмотров:
1585
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:C/I:C/A:C/E:P/RL:U/RC:C) = Base:9.3/Temporal:8.4
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
OPIE 2.x
Уязвимые версии: OPIE 2.4, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки завышения на единицу в функции __opiereadrec() в файле readrec.c. Удаленный пользователь может вызвать однобайтное переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.inner.net/opie

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://site.pi3.com.pl/adv/libopie-adv.txt

или введите имя

CAPTCHA